dkfr.net
当前位置:首页 >> 浏览器iE8不支持用jquEry吗 >>

浏览器iE8不支持用jquEry吗

2.0以上版本的jQuery已经不再支持IE8及以下版本的IE浏览器,所以才出现了问题。 解决方法很简单: 相关问题: Jquery从2.x版本开始已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。如果需要兼容低版本的IE版本,建议使用原生JS或者低版本的Jqu...

jQuery新版本已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。 如果项目需要兼容IE低版本,需要使用jQuery1.x版本,从2.x开始已经不兼容IE6、7、8了。 以下为jQuery官网的通知: jQuery 2.x has the same API as jQuery 1.x, but does not su...

你好,很高兴为你作答。 对于IE 8 来说,jquery的低版本是可以兼容的。 不过在2.0版本之后,官方已经宣布不再支持IE 6 7 8版本的浏览器。 所以,使用诸如比较常用的1.4、1.7版本的jquery,在IE 8下面使用是没有问题的。

当然有不兼容的地方啊,但只是极少数地方,也要看看你的jquery包都是哪个版本的~ 建议用1.8.3版本最稳定,1.4.3也是个稳定版本。但用新不用旧还是1.8.3吧,2.0后都不支持IE 6 7 8了

jQuery2以前的版本是支持IE8的 如果升级到jQuery2以后的版本,就不再支持IE8了

jquery10中$.browser方法已经废弃了 jquery现在只能检测浏览器是否支持某特性, 业界也推荐这么做 html5的新特性ie8以下不支持, 所以可以用下面的方法进行判断 $.support.leadingWhitespace 如果是false, 就是ie8及以下, 如果是true, 就是新的浏...

jQuery新版本已经不再进行IE低版本(IE6、IE7、IE8)的兼容性处理。 如果项目需要兼容IE低版本,需要使用jQuery1.x版本,从2.x开始已经不兼容IE6、7、8了。 以下为jQuery官网的通知: jQuery 2.x has the same API as jQuery 1.x, but does not su...

jQuery 2.x 就是针对 IE9 以上的。 兼容 IE 低版本 还是用 jQuery 1.x 版本吧。 https://code.jquery.com/jquery/ 这是 jQuery 所有版本。

click还是支持的不知道你是怎么绑定的?jquery版本是多少? $(#selector").click(function(){ }); 应该没问题 如果用$("selector").bind("click",function(){ }); 高版本的jquery取消了bind

jQuery从2.0版开始不再支持IE6、IE7和IE8. 请引用2.0以下的版本即可.

网站首页 | 网站地图
All rights reserved Powered by www.dkfr.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com